Jump to content
Sign in to follow this  
contrabandvr

TV Style Config crash

Recommended Posts

Hi,

whenever i go into TV Style config, load a profile, then try and click any of the preview buttons, i get this error pop up:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.BadImageFormatException:  is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
   at TVSTYLECONFIG.Form4.Button4_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
TVSTYLECONFIG
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/rFactor/Plugins/TvStyle/TVSTYLECONFIG.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Im running Vista 64bit, could this be the problem?

Thanks.

Share this post


Link to post
Share on other sites

hi guys i have the same problem

i'm running a 64bit software of vista

but when i would have a prewiew in the tv display i have the same error like contrabandvr

so how could i change this problem???

is there a update for tv display for 64bit??

pls give me a answer

Share this post


Link to post
Share on other sites

I've got the same problem! I've read the link that contrabandvr has posted, but i didn't understood how to make it work.

If someone can explain me, i would be very grateful!

Share this post


Link to post
Share on other sites
Preview Button doesn't work with 64bit.

Preview system is a 3rd part library external to TV-Config.

Sorry.

I know exactly how to fix that... I would just need the source code of v0.91 :rolleyes:

you just have to set a property into the compilator to compilate specific for x86

otherwise it loads your program with framework x64

Edited by prunn

Share this post


Link to post
Share on other sites

ya but that is so simple, it should have been fixed awhile ago

exemple in visual studio 2005 in the project properties

fixx.jpg

I did a search yesterday about that and your program itself will run fine into framework x64, the thing that make it crash is that devIL.net.dll won't run into x64 framework, so you either have the choice to recompile it in x64 or tell the main program to use x86 framework

Share this post


Link to post
Share on other sites

if you don't believe me...

<!--quoteo(post=0:date=:name=http://www.mastropaolo.com/devildotnet/)--><div class='quotetop'>CITAZIONE (http://www.mastropaolo.com/devildotnet/)</div><div class='quotemain'><!--quotec-->NOTE : When using Devil.NET 1.2 on VS2005, remind to set your projects to use the x86 CPU. Otherwise the program may fail to run on x64 platforms.<!--QuoteEnd--></div><!--QuoteEEnd-->

in your case Devil.NET 1.0 gets the same treatment to work

<a href="http://www.mastropaolo.com/devildotnet/" target="_blank">http://www.mastropaolo.com/devildotnet/</a>

So has anybody fixed this!?!? It isn't so hard, please release the source or do it yourselves, we need the x86 & x64 fix as more and more people are running Windows 7 x64 nowadays!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...